在XAMPP上安装SVN的一个注意事项

在之前版本的XAMPP(如1.6.5)上,apache运行SVN所依赖的mod_authz_svn.so和mod_dav_svn.so两个文件是已经存在的,并且为了让XAMPP能够和SVN一起工作,XAMPP的开发者重新编译了这两个文件。而在新版本的XAMPP中(可能是从1.6.7开始),作者删除了这两个文件,你必须从svn的bin目录中拷贝这两个文件。

因此,在XAMPP上安装SVN时,必须先检查“xampp\apache\modules”目录中是否有mod_authz_svn.so和mod_dav_svn.so这两个文件。如果已经有了,那么就不需要从svn中拷贝了。

不过这里仍然有一个问题,xampp重新编译过的mod_authz_svn.so和mod_dav_svn.so文件只能支持某个指定版本的SVN,XAMPP版本和它支持的SVN版本是映射关系(即任意版本的XAMPP只支持特定的SVN版本)。

很遗憾,XAMPP的开发者并没有发布XAMPP和SVN版本对应关系表。如果你发现你的XAMPP无法和SVN一同工作,排除了所有安装中可能出现的问题后,最后一个原因一定是XAMPP和SVN版本不对应。如果真的遇到这种情况,请升级XAMPP到1.6.7以上(含1.6.7。1.6.6可能也行,但我不确定)版本,直接从svn中拷贝mod_authz_svn.so和mod_dav_svn.so。

发表评论

电子邮件地址不会被公开。 必填项已用*标注